Multilink PPP Quick Start and Examples


ImageStream's Version 4.1.9 release includes support for the Multilink PPP (MLPPP) datalink protocol. MLPPP aggregates multiple physical WAN links into a single multilink bundle. Data is sequenced, split, and transmitted down the individual interfaces that are members of the multilink bundle. On the receive side the information is recombined and resequenced before being passed to the network layer.

MLPPP can be used to bond together two T1 circuits into a virtual circuit with the effective bandwidth of 3Mbps. Besides from providing access to the aggregate bandwidth MLPPP can also reduce latency and jitter.
====ETHERNET===================== 192.168.1.0/24 ===
        |
        | LAN IP: 192.168.1.100
+-------+-------------+
|                     |
|      Router A       |
| Serial0     Serial1 |
+----+-----------+----+
     |           | MLPPP IP: 192.168.54.1/30 (255.255.255.252)
     |           |
    [-]         [-]CSU/DSU (may be integrated on WAN card)
     |           |
     |  PTP WAN  |
     |  Cicuits  |
    [-]         [-]CSU/DSU (may be integrated on WAN card)
     |           |
     |           | MLPPP IP: 192.168.54.2/30 (255.255.255.252)
+----+-----------+----+
| Serial0     Serial1 |
|      Router B       |
|                     |
+-------+-------------+
        | LAN IP: 192.168.2.200
        |
====ETHERNET===================== 192.168.2.0/24 ===

Before You Start

Be sure to have three separate IP subnets, one for the Multilink Interface network and two for the Ethernets connected to the routers. Each side of the MLPPP interface must have it's own IP address from the same IP network. Since they are on the same IP network, they will have the same netmask.

These IP network addresses are given to you by your Internet Service Provider, your leased line carrier, or by ARIN. If you do not plan to connect you network to the Internet, you can use an IP network address set aside for private use. The IP network address for private use can be found in RFC 1597. Most people will use 192.168.0.0 as we have in this example.

Before you can configure MLPPP the physical interfaces must be configured. See the following chapters in the Router Install manual:
  • Configuring a Synchronous Serial WAN Interface
  • Configuring a Integrated CSU/DSU WAN Interface

Configuring The WAN Ports

In this example, we are going to assume the following:
  • Router A has an Ethernet IP address of 192.168.1.100 with a netmask of 255.255.255.0
  • Router A has a MLPPP IP address of 192.168.54.1 with a netmask of 255.255.255.252
  • Router B has an Ethernet IP address of 192.168.2.200 with a netmask of 255.255.255.0
  • Router B has a MLPPP IP address of 192.168.54.2 with a netmask of 255.255.255.252
  • Router A is providing Internet access to Router B.
  • The MLPPP interface is composed of WAN ports Serial0 and Serial1.
The IP addresses used in this Technical Note are examples only. You will need to use an IP network given to you by your Inte rnet Service Provider.

Router A

!
version 2.00
!
interface Ethernet0
 ip address 192.168.1.100 255.255.255.0
!
interface Serial0
 description T1 Connection to Router B
 encapsulation ppp
 ppp multilink
 multilink-group 1
!
interface Serial1
 description T1 Connection to Router B
 encapsulation ppp
 ppp multilink
 multilink-group 1
!
interface Multilink1
 ip address 192.168.54.1 255.255.255.252
!
ip route add default via 192.168.1.1
ip route add 192.168.2.0/24 dev Multilink1
!
end

Router B

!
version 2.00
!
interface Ethernet0
 ip address 192.168.2.200 255.255.255.0
!
interface Serial0
 description T1 Connection to Router A
 encapsulation ppp
 ppp multilink
 multilink-group 1
!
interface Serial1
 description T1 Connection to Router A
 encapsulation ppp
 ppp multilink
 multilink-group 1
!
interface Multilink1
 ip address 192.168.54.2 255.255.255.252
!
ip route add default dev Multilink1
#Alternate default route command
#ip route 0.0.0.0 0.0.0.0 192.168.54.1
!
end

Command Syntax for MLPPP master interface

interface MultilinkXX
-- where XX is the bundle number. The location of a Multilink interface declaration in the interface configuration file is not important. By convention, the first Multilink device is Multilink0, though you may assign any number. You do not need to specify an encapsulation type or bandwidth, as both will be ignored. You must specify an ip address. A description field is optional.
ppp multilink fragmentation disabled
-- Disable PPP Multilink fragmentation. Packets will not be split before being transmitted.
ppp short-header
-- Requests for a short MLPPP header during protocol negotiation.
ppp voip <value>
-- Disables fragmentation on packets less then <value> bytes. Command not valid when fragmentation is disabled for the bundle.
ppp multilink mrru local <value>
-- Requests the local MRRU (Maximum Receive Reconstructed Unit) be set to <value> during protocol negotiation. Command not valid when fragmentation is disabled for the bundle.
ppp multilink mrru remote <value>
-- Requests the remote MRRU (Maximum Receive Reconstructed Unit) be set to <value> during protocol negotiation. Command not valid when fragmentation is disabled for the bundle.

Command Syntax for MLPPP physical WAN interfaces

ppp multilink
-- Enables Multilink PPP on the Serial interface. The command accepts no parameters.
multilink-group XX
-- Assigns the interface to a multilink bundle where xx is the bundle number.

Troubleshooting

If the port does not have an "up" status for both hardware and protocol in the interface statistics output (Option 2 from the Main menu) do the following:

If hardware shows "down", check your cable connections and ensure that you have connected to the correct port. If yo u have connected to the correct port, double-check the telephone company smart jack or other telephone company-installed equi pment for your circuit. The smart jack should show no red alarms if the cables are connected. If, after connecting the cabl es correctly, you have errors on the telephone company equipment, contact your line provider for assistance.

If hardware shows "up", but protocol shows "down", you should see the PPP negotiation and see the status of the WAN p ort change to up. At this point you should be able to ping the other side.

If you have an external CSU/DSU, put the CSU/DSU into a local loopback. This will cause each packet sent to the CSU/D SU to reflect back to the WAN port. This is for testing only, the line will not function while the CSU/DSU is in a local loop back. If, in the interface statistics detail output for the port, you see transmitted packets immediately received on the sam e port, then you can determine the following facts:
  1. The WAN port on the router is sending and receiving data.
  2. The cable and connectors between the router and the CSU/DSU are functioning.
  3. The DTE port on the CSU/DSU is functioning.
  4. THE ROUTER IS FUNCTIONING AS IT SHOULD.
If you don't get your packets back immediately on the same interface:
  1. For cards with a software-selectable serial interface, check that you have specified the correct wiring specification ( V.35, RS232, RS422/X.21). The "dctype" command is typically set to V.35 (the default) in North America and RS422 in Europe a nd Asia.
  2. That all cables are securely connected.
  3. Begin swapping hardware, cables, CSU/DSU, etc.
If you get your packets back immediately, but the line protocol status is not "up":
  1. Check the CSU/DSU settings such as clocking, etc. Almost always the CSU/DSU should be set for external clocking. Your l ine provider typically provides the clock. It's not a bad idea to verify any external CSU/DSU settings with the manufacturer.
  2. Have their telephone carrier test the line. Requesting a hard copy of the test results will often get you a better test .
If the line protocol status is "up" but you can't ping the other side:
  1. Double check settings. Make sure that the IP address for the WAN port on both sides are in the same subnet.
  2. Do a traceroute from your workstation through the local (to you) router to the router in trouble. Then do a traceroute from the router in trouble (assuming you can get to it) back to your workstation. The problem will lie in the gap between the two traceroutes.
  3. Make sure the default gateway is set to the upstream router or the serial device used for the upstream connection, as i n our example above on Router B.



References: RFC 1990
Technical Support
Home >
Technical Notes >
MLPPP-Quick-Start

Software Versions

General Availability
(GA) Releases


Envoy: 4.4.1-30
Others: 4.4.1-30
IDCA:

ICNA Certification


Get Your
ImageStream
Certification