Multilink Frame-Relay Quick Start and Examples


ImageStream's Version 4.1.12 release includes support for the Multilink Frame Relay (MLFR) datalink protocol. MLFR aggregates multiple physical WAN links into a single multilink bundle to interface with the Frame Relay network. Traffic transferred across the multilink bundle is load balanced over the individual WAN links that are members of the bundle.

MLFR can be used to bond together two T1 circuits into a bundle with the effective bandwidth of 3Mbps to the Frame Relay Network.
====ETHERNET===================== 192.168.1.0/24 ===
        |
        | LAN IP: 192.168.1.100
+-------+-------------+
|                     |
|      Router A       |
| Serial0     Serial1 |
+----+-----------+----+
     |           | MLFR PVC IP: 192.168.54.1/30 (255.255.255.252)
     |           |
    [-]         [-]CSU/DSU (may be integrated on WAN card)
     |           |
     |  T1 WAN   |
     |  Cicuits  |
     |           |
     |           | 
 ----+-----------+----
/                     \ 
|     Frame Relay      |
|        Cloud         |
\                     /
 ---------------------

Before You Start

Be sure to have two separate IP subnets, one for the Multilink Interface network and one for the Ethernet connected to the routers.

These IP network addresses are given to you by your Internet Service Provider, your leased line carrier, or by ARIN. If you do not plan to connect you network to the Internet, you can use an IP network address set aside for private use. The IP network address for private use can be found in RFC 1597. Most people will use 192.168.0.0 as we have in this example.

Before you can configure MLFR the physical interfaces must be configured. See the following chapters in the Router Install manual:
  • Configuring a Synchronous Serial WAN Interface
  • Configuring a Integrated CSU/DSU WAN Interface

Configuring The WAN Ports

In this example, we are going to assume the following:
  • Router A has an Ethernet IP address of 192.168.1.100 with a netmask of 255.255.255.0
  • The Multilink Frame Relay has a permanent virtual circuit (PVC) of 500
  • The PVC has a IP address of 192.168.54.1 with a netmask of 255.255.255.252
  • The MLFR interface is composed of WAN ports Serial0 and Serial1.
The IP addresses and PVC number used in this Technical Note are examples only. You will need to use an IP network and PVC number given to you by your Internet Service Provider.

Router A

!
version 2.00
!
interface Ethernet0
 ip address 192.168.1.100 255.255.255.0
!
interface Serial0
 description T1 Connection to Frame Relay Cloud 
 encapsulation frame-relay MFR1 
!
interface Serial1
 description T1 Connection to Frame Relay Cloud 
 encapsulation frame-relay MFR1 
!
interface MFR1
 encapsulation frame-relay
!
interface MFR1.1
 encapsulation frame-relay ietf
 frame-relay interface-dlci 500
 ip address 192.168.54.1 255.255.255.252 
!
ip route add default dev MFR1.1
!
end

Command Syntax for physical interfaces

encapsulation frame-relay MFRXX
-- Assigns the interface to a Multilink Frame-Relay bundle where xx is the bundle number.

Command Syntax for MLFR Master interface

interface MFRXX
-- where XX is the bundle number. The location of a Multilink interface declaration in the interface configuration file is not important. By convention, the first Multilink device is MFR1, though you may assign any number. You do not need to specify bandwidth, as it is calculated. A description field is optional.
frame-relay lmi-type { ansi | cisco | ccitt | none }
-- Specifies the type of LMI to use on this interface. ANSI (also known as "Annex D" or, regrettably, "LMI") is the default and most common value. Using the none keyword will disable the use of LMI.
frame-relay interval <value>
-- Specifies the LMI interval in seconds.

Command Syntax for MLFR sub-interface

interface MFRXX.YY
-- where XX is the bundle number and YY is the sub-interface number. The location of a Multilink sub-interface declaration in the interface configuration file is not important. By convention, the first sub-interface number device is 1, though you may assign any number. A description and bandwidth field is optional.
encapsulation frame-relay ietf
-- Specifies the use of the ietf frame-relay standard on this interface.
frame-relay interface-dlci <value>
-- Specifies the data link connection identifier (DLCI) of the permanent virtual circuit (PVC) for the sub-interface.
Technical Support
Home >
Technical Notes >
MLFR-Quick-Start

Software Versions

General Availability
(GA) Releases


Envoy: 4.4.1-30
Others: 4.4.1-30
IDCA:

ICNA Certification


Get Your
ImageStream
Certification