Configuration example for RFC 1483 ATM DSL using SoftCell IMA

This sample configuration shows an ImageStream router connected to Digital Subscriber Line aggregation circuits bonded together using ImageStream's SoftCell technology and Inverse Multiplexing for ATM (IMA) protocol. In this example, the IMA group includes 3 T1 lines. Each PVC represents a DSL customer terminated on the router. This example uses the "atm route-bridged ip" command. This command automatically sets up a bridge group, binds the ATM subinterface to it. "atm route-bridged ip" also turns off the spanning tree protocol on the port, sets the forward time to one second and enables proxy ARP so that each PVC can communicate with other PVCs, yet still have a netmask larger than a /32. All routes added to the ATM subinterface are redirected by the router to the automatic bridge group instead.
====ETHERNET===================== 192.168.1.0/24 ===
        |
        | LAN IP: 192.168.1.100
+-------+--------+
|                |
|  Router A      |
|   Serial0      |
+-------+--------+
      | | | WAN IP: 192.168.54.1/24 (255.255.255.0)
      | | |
      | | |
      | | ATM WAN
|-------|--------|
|       |        | 
|       |        |
+       +        +
PVC     PVC      PVC
1/101   1/102    1/103

Before You Start

Be sure to have three separate IP subnets, one for the WAN network and two for the Ethernets connected to the routers. Each WAN port connected to the point-to-point WAN must have it's own IP address from the same IP network. Since they are on the same IP network, they will have the same netmask.

These IP network addresses are given to you by your Internet Service Provider, your leased line carrier, or by ARIN. If you do not plan to connect you network to the Internet, you can use an IP network address set aside for private use. The IP network address for private use can be found in RFC 1597. Most people will use 192.168.0.0 as we have in this example.

Configuring The WAN Ports

In this example, we are going to assume the following:
  • Router A has an Ethernet IP address of 192.168.1.100 with a netmask of 255.255.255.0
  • Router A has a WAN IP address of 192.168.54.1 with a netmask of 255.255.255.0
  • The DSL Customer with VPI 1 and VCI 101 has an IP address of 192.168.0.10
  • The DSL Customer with VPI 1 and VCI 102 has an IP address of 192.168.0.11
  • The DSL Customer with VPI 1 and VCI 103 has an IP address of 192.168.0.12
The IP addresses used in this Technical Note are examples only. You will need to use an IP network given to you by your Internet Service Provider.

Router A

!
interface Loopback0
 ip address 192.168.0.1 255.255.255.0
!
interface Serial0
 description IMA Port 0
 encapsulation atm
 ima-group 0
!
interface Serial1
 description IMA Port 1
 encapsulation atm
 ima-group 0
!
interface Serial0
 description IMA Port 2
 encapsulation atm
 ima-group 0
!
interface IMA0
 description Main interface
!
interface IMA0.101
 description CustomerA
 ip unnumbered Loopback0
 atm route-bridged ip
 pvc 1/101
 encapsulation aal5snap
!
interface IMA0.102
 description CustomerB
 ip unnumbered Loopback0
 atm route-bridged ip
 pvc 1/102
 encapsulation aal5snap
!
interface IMA0.103
 description CustomerC
 ip unnumbered Loopback0
 atm route-bridged ip
 pvc 1/103
 encapsulation aal5snap
!
ip route 192.168.0.10 255.255.255.255 IMA0.101
ip route 192.168.0.11 255.255.255.255 IMA0.102
ip route 192.168.0.12 255.255.255.255 IMA0.103
!
end
The router will automatically configure up a brIMA0.101 bridge for the first subinterface, a brIMA0.102 subinterface for the second and a brIMA0.103 subinterface for the third. The configuration also adds individual IP routes to 192.168.0.10/32 via brIMA0.101 (instead of IMA0.101), a route to 192.168.0.11/32 via brIMA0.102 and a route to 192.168.0.12/32 via brIMA0.103. ATM routed bridge encapsulation reduces the security risks and added broadcast traffic associated with bridging all customers into a single bridge group. This configuration method simplifies the configuration by reducing the number and complexity of the devices required to support each customer.

ImageStream's SoftCell ATM support handles all ATM cell segmentation and reassembly, and sends the special cells required from the IMA protocol. As with other T1 IMA solutions, the IMA PVCs only support the UBR (unspecified bit rate) ATM Quality of Service type. Other ATM QoS configurations, such as VBR, CBR or ABR, are ignored. The ATM IMA group may require as long as 15 seconds to synchronize with the ATM network and enable the IMA group. This is normal. The interface statistics output (Option 2 from the Main menu) will report the status of the individual T1s and the IMA group.

Troubleshooting

If the port does not have an "up" status for both hardware and protocol in the interface statistics output (Option 2 from the Main menu) do the following:

If hardware shows "down", check your cable connections and ensure that you have connected to the correct port. If you have connected to the correct port, double-check the telephone company smart jack or other telephone company-installed equipment for your circuit. The smart jack should show no red alarms if the cables are connected. If, after connecting the cables correctly, you have errors on the telephone company equipment, contact your line provider for assistance.

If you have a T1 CSU/DSU, put the CSU/DSU into a local loopback. This will cause each packet sent to the CSU/DSU to reflect back to the WAN port. This is for testing only, the line will not function while the CSU/DSU is in a local loopback. If, in the interface statistics detail output for the port, you see transmitted packets immediately received on the same port, then you can determine the following facts:
  1. The WAN port on the router is sending and receiving data.
  2. The cable and connectors between the router and the CSU/DSU are functioning.
  3. The DTE port on the CSU/DSU is functioning.
  4. THE ROUTER IS FUNCTIONING AS IT SHOULD.
If you don't get your packets back immediately on the same interface:
  1. For cards with a software-selectable serial interface, check that you have specified the correct wiring specification (V.35, RS232, RS422/X.21). The "dctype" command is typically set to V.35 (the default) in North America and RS422 in Europe and Asia.
  2. That all cables are securely connected.
  3. Begin swapping hardware, cables, CSU/DSU, etc.
If you get your packets back immediately, but the line protocol status is not "up":
  1. Check the CSU/DSU settings such as clocking, etc. Almost always the CSU/DSU should be set for external clocking. Your line provider typically provides the clock. It's not a bad idea to verify any external CSU/DSU settings with the manufacturer.
  2. Have their telephone carrier test the line. Requesting a hard copy of the test results will often get you a better test.
If the line protocol status is "up" but you can't ping the other side:
  1. Double check settings. Make sure that the IP address for the WAN port on both sides are in the same subnet.
  2. Do a traceroute from your workstation through the local (to you) router to the router in trouble. Then do a traceroute from the router in trouble (assuming you can get to it) back to your workstation. The problem will lie in the gap between the two traceroutes.
  3. Make sure the default gateway is set to the upstream router or the serial device used for the upstream connection, as in our example above on Router B.
Technical Support
Home >
Technical Notes >
ATM IMA Configuration

Software Versions

General Availability
(GA) Releases


Envoy: 4.4.1-30
Others: 4.4.1-30
IDCA:

ICNA Certification


Get Your
ImageStream
Certification